VEVOR be aware

MichaelMoore740

New member
Local time
11:39 PM
Joined
Mar 22, 2024
Messages
7
Location
Oregon USA
So I got a my1020D 48v 1800w motor w/ controller and throttle that was Dec. 1st 2023 cost $117.00 and since I am disabled and with some bank and parts issues I could only go so fast. I would get the first parts right around christmas time. Of course the sprockets both motor and asle failded to work motor spun a h pattern back into a hole ( not Hardened ) axle size of shaft issue oh sorry My build is a Trike first time was front wheel hub all went togeather real nice 48v 1000w w/ 30ah 20ah and 13ah for backup. Then I got well say a wild hair after seeing the vevor motor 1800w 3 speed with forward and reverse so I started mounting in basket with it being so close to the axle any deveance in sprockets and chain causes a pretty loud pop and slight grind and with all the sprockets being 5/8 or so I thought there was always a little to a bad wobble and took me 3 times to get it worked out and the axle is 12mm and so I found the shim to fix the issue and i had only rode 50 yards as not to harm the motor or trike.then I am ready to rock and roll and the motor zip nothing and that started the very long and well kinda stupid messaging back and forth with vevor who I got direct as they show a 12 month warranty on every page. 3 weeks they ask me things or made comments about sprockets need to be 7 to 1 I never said aything concerning that and i ask what does that have to due with a motor that just quit working. Oh ya and every time they was requesting photos and video of my issue well there is not much to photo all the wiring was done with correct matching connectors I did not cut any off the controller. 3 batteries of course they complained bout them too. and then the restriction of only 5mb file of pic's and vids come on I knew they was low on these motors but they drug the whole thing out for 3 weeks till I was pretty hot around the collor. They fessed up and I only got 90.00 of my cash back I had to tear apart my pedal chopper cause i migrated the works off the trike to it and the whole thing could have been handled so much better and faster if they jut admited they was out of the things. So here I am no where but down a couple hundred for sprockets amd chain 1/4 aluminum plating for mounting lights etc and back to the orginal build and a tore apart pedal chopper so be ware of Vevor So the middle pic is how I am working on doing next month anyway that is my Vevor nightmare
 

Attachments

  • IMG_20231224_134244.jpg
    IMG_20231224_134244.jpg
    165.3 KB · Views: 41
  • IMG_20240312_143609.jpg
    IMG_20240312_143609.jpg
    176.3 KB · Views: 38
  • IMG_20240316_150915.jpg
    IMG_20240316_150915.jpg
    234.8 KB · Views: 40
I have purchased 2 'affordable' E kits. one on ebay, the other off Walmart. 'BEWARE!' If a kit does not arrive on the original
carton & foam packing, you've been ripped off with some one's junk! it'll be a box of assorted,(often redundant), parts from
various kits & will never work not matter how many error codes you try to solve or how many times you check all connections.
Avoid any thing coming from 'Vegas'! Plug together the whole kit & harness & test it with a battery 1st to make sure it works
before ever attempting to install it :oops:!!!
 
So I got a my1020D 48v 1800w motor w/ controller and throttle that was Dec. 1st 2023 cost $117.00 and since I am disabled and with some bank and parts issues I could only go so fast. I would get the first parts right around christmas time. Of course the sprockets both motor and asle failded to work motor spun a h pattern back into a hole ( not Hardened ) axle size of shaft issue oh sorry My build is a Trike first time was front wheel hub all went togeather real nice 48v 1000w w/ 30ah 20ah and 13ah for backup. Then I got well say a wild hair after seeing the vevor motor 1800w 3 speed with forward and reverse so I started mounting in basket with it being so close to the axle any deveance in sprockets and chain causes a pretty loud pop and slight grind and with all the sprockets being 5/8 or so I thought there was always a little to a bad wobble and took me 3 times to get it worked out and the axle is 12mm and so I found the shim to fix the issue and i had only rode 50 yards as not to harm the motor or trike.then I am ready to rock and roll and the motor zip nothing and that started the very long and well kinda stupid messaging back and forth with vevor who I got direct as they show a 12 month warranty on every page. 3 weeks they ask me things or made comments about sprockets need to be 7 to 1 I never said aything concerning that and i ask what does that have to due with a motor that just quit working. Oh ya and every time they was requesting photos and video of my issue well there is not much to photo all the wiring was done with correct matching connectors I did not cut any off the controller. 3 batteries of course they complained bout them too. and then the restriction of only 5mb file of pic's and vids come on I knew they was low on these motors but they drug the whole thing out for 3 weeks till I was pretty hot around the collor. They fessed up and I only got 90.00 of my cash back I had to tear apart my pedal chopper cause i migrated the works off the trike to it and the whole thing could have been handled so much better and faster if they jut admited they was out of the things. So here I am no where but down a couple hundred for sprockets amd chain 1/4 aluminum plating for mounting lights etc and back to the orginal build and a tore apart pedal chopper so be ware of Vevor So the middle pic is how I am working on doing next month anyway that is my Vevor nightmare
Any suggestions for a 'reliabie', 'ethical' site for a front wheel kit? Anyone?
 
I have purchased 2 'affordable' E kits. one on ebay, the other off Walmart. 'BEWARE!' If a kit does not arrive on the original
carton & foam packing, you've been ripped off with some one's junk! it'll be a box of assorted,(often redundant), parts from
various kits & will never work not matter how many error codes you try to solve or how many times you check all connections.
Avoid any thing coming from 'Vegas'! Plug together the whole kit & harness & test it with a battery 1st to make sure it works
before ever attempting to install it :oops:!!!
Have found a cool solution in a company I used some time ago, but forgot, Calibike.:cool:They're selling a geared 52v 1500w kit
that weighs 3,5 kilos as opposed to a 22 kilo Violamart. I know this will arrive in the original pkg. & not a bunch of junk in a box,
$375 & I know it will work for my fast, long range, hybrid gas/electric touring bike with solar trailer. This motor will do 37mph,
or about the same as my C.A.R.B. certified, extended life, super clean, no smoke, 39cc, 2 stroke. Again I can realistically
travel a 1000+ miles in a reasonable time frame while charging one battery with engine(50 mi. per liter), & a second with solar.
As a front whl, I can keep my treble chain ring, (not possible with mid-drive). With both I needn't fear cooking my e-motor on a
long pass. & can simply charge with nothing on a long descent. Now if only my email gets unblocked by yahoo & google fighting
over my acct, I may be able to place the order. Two of my latest online purchases have failed to arrive in more than a mo.:unsure:
 
Back
Top