Sw900 display error code

Alannababy2014

New member
Local time
6:46 AM
Joined
Jan 25, 2024
Messages
9
Location
Uk
Hello can anyone on here tell me what possible problem error 08 code mean?? I've already replaced thottle and 1t4 cables but it still there an motor won't move at all, it's a new kit I was using it for 10min until it just cut off.
 

Attachments

  • 20240124_134138.jpg
    20240124_134138.jpg
    144 KB · Views: 40
I can't find an sw900 dislay tye same as this so I'm not sure if the error code on this dislay is same as normal sw900 displays
 
could be anything from throttle to hall stuff in motor...
Yeah that's what I've heard so I replaced throttle and caes but error code 08 still showing and motor not moving, I'm just waiting for new controller hopeing that will fix the problem, back to my original question about limit on display only goes as far as 20amps, that picture I post of my display have you seen an sw900 display like that? I can't find same one as it online
 
 
Links to eBay may include affiliate code. If you click on an eBay link and make a purchase, this forum may earn a small commission.
Yeah that's what I've heard so I replaced throttle and caes but error code 08 still showing and motor not moving, I'm just waiting for new controller hopeing that will fix the problem, back to my original question about limit on display only goes as far as 20amps, that picture I post of my display have you seen an sw900 display like that? I can't find same one as it online
Yeah i seen them i just never use them. I use older models of SW900 with
50 amp and 72 volt capabilities.
 
My last display was also the older dislay of sw900, the one I currently have is also 36/72v display aswel. When get error code fixed I can take another look again at the amp limit see if I can manage to get past the 20a limit. If not I will get tye older model sw900 so can put amp limit to 40a my controllers rated 22a with max 45a with 2000w motor runing off 60v 20ah battery so running it on current display 20a is less than what it's capable of
 
Yeah that's what I've heard so I replaced throttle and caes but error code 08 still showing and motor not moving, I'm just waiting for new controller hopeing that will fix the problem, back to my original question about limit on display only goes as far as 20amps, that picture I post of my display have you seen an sw900 display like that? I can't find same one as it online
Hello bro did getting a new controller end up fixing the problem ?
 
Hello can anyone on here tell me what possible problem error 08 code mean?? I've already replaced thottle and 1t4 cables but it still there a motor won't move at all, it's a new kit I was using it for 10min until it just cut off.
You found anything to fix it having this problem atm
 
Back
Top