Rad City 5 plus new out of the box would not work in PAS mode.

Marvin

New member
Local time
2:28 PM
Joined
Aug 26, 2022
Messages
1
New to the forum but thought I would let everyone know my issues. We bought two Rad City 5 bikes. The Rad City 5 Plus step through is working fine. The Rad City 5 Plus high step would not work in power assist mode but the throttle would work. I would call Rad City customer service and after waitng from 45 minutes to 85 minutes would reach someone. We deducted it was the pedal sensor. Took a week and the wrong sensor arrived. Call them up and they would ship the right one. After four days call them back because no shipment was made and they were out of stock and idea when. So I had the bike about three weeks and it would not work. Rad city was slow to answer and emails were three days before an answer. I loaded it up and took it to a bike shop. It appears they have a better contact email and we do. The sensor was not the problem and now Rad City is sending a controller to the bike shop for a try. I cannot recommend Rad City at the moment because the access to customer service is so limited. I am glade I had a bike shop to help fix this issue. More soon.
I did get an email when I submitted to return it because it was not working and received an email that there was no guarantee that a return could happen unless the senior review team reviewed and agreed.
We will wait to see if the bike shop can resolve it but as for now I could not buy from Rad City again at the moment because if something is wrong you cannot get resolution in a timely manner.
 
Welcome to the forum, Marvin.

Sorry to hear of your awful experience. It seems like poor customer service is a recurring theme with so many ebike makers out there. I imagine some of it may be related to current worker shortages, but I think in most cases it is just a cost savings business model unfortunately.
 
Usually when the pas doesn't work it's because the magnet disk it too far from the sensor. Did anyone try moving it closer to the sensor?
 
New to the forum but thought I would let everyone know my issues. We bought two Rad City 5 bikes. The Rad City 5 Plus step through is working fine. The Rad City 5 Plus high step would not work in power assist mode but the throttle would work. I would call Rad City customer service and after waitng from 45 minutes to 85 minutes would reach someone. We deducted it was the pedal sensor. Took a week and the wrong sensor arrived. Call them up and they would ship the right one. After four days call them back because no shipment was made and they were out of stock and idea when. So I had the bike about three weeks and it would not work. Rad city was slow to answer and emails were three days before an answer. I loaded it up and took it to a bike shop. It appears they have a better contact email and we do. The sensor was not the problem and now Rad City is sending a controller to the bike shop for a try. I cannot recommend Rad City at the moment because the access to customer service is so limited. I am glade I had a bike shop to help fix this issue. More soon.
I did get an email when I submitted to return it because it was not working and received an email that there was no guarantee that a return could happen unless the senior review team reviewed and agreed.
We will wait to see if the bike shop can resolve it but as for now I could not buy from Rad City again at the moment because if something is wrong you cannot get resolution in a timely manner.
I had the same problem with another brand,but they had to go thru the office in china.waited 19 days for a replacement 1000 watt rear motor and the derailleur selector on the handle bars. When the order arrived no rear motor and a thumb throttle. NO GEAR SELECTOR. RETURNED THE SCRAP METAL. And took 60 days to get refund and $376.02 shipping.bought a generic WTVA/VTUVIA for 1299.00@ amazon and no problem for 2 years
 
Back
Top