Tesgo Hummer Pro Error Code 21

Ramrod1015

New member
Local time
10:43 AM
Joined
May 31, 2022
Messages
2
I have a Tesgo Hummer Pro folding bike, and today it stopped, and I am getting an error 21 code. I only have 75 miles on it. Does anyone know a fix for this?
 
Well, I would start by looking up that error code in your owner's manual.

Next, find the 15 other brand names that bike is sold under, so that you might have a decent chance of finding the manual online.
 
Manual was of no help. What other brands use the same configuration? When I turn the bike on, the display comes up, but when you press the throttle, you can hear a faint click in the hub motor.
 
Google the frigging error code and keep trying until you find a list.

I don't have them all memorized and I have never heard of your bike brand and I am not going to do the Google search for you.
 
I have a Tesgo Hummer Pro folding bike, and today it stopped, and I am getting an error 21 code. I only have 75 miles on it. Does anyone know a fix for this?
Did you ever get this resolved? Dealing with this now and since there isn't a manual, waiting for support to respond back.
 
"send a email to there support team there very quick to respond back"
NOT SO MUCH

I'm having the same problem died at 200mi. 0 response after many many inquiries.
 
"The answer was the controller inside the bike frame has a nick in the wires and shorted out. They sent a new controller."

You are exactly right, thank you very,very much. Turns out the idiots who assembled it at the factory just push the controller box(with aluminum metal heat sink with sharp edges) inside the compartment with the wires and when riding it the box jumbles around and wears through the wires shorting them out on each other. (your welcome CHINA)

I repaired the melted wires and put a piece of velcro on the heat sink and one on the inside of the box to keep it mounted. They still haven't responded to any of my requests. If you own this bike i would reccomend doing this right away. Pedaling this tank from deep in the woods is not much fun.
 

Attachments

  • 20220723_080528.jpg
    20220723_080528.jpg
    128.5 KB · Views: 358
  • 20220723_080831.jpg
    20220723_080831.jpg
    71.5 KB · Views: 305
  • 20220723_083308.jpg
    20220723_083308.jpg
    144.5 KB · Views: 310
Two tesgo with same issue. Tesgo sent me 2 new controller. Once changed for new one it now appears the short affected the motor. Anyone else with this issue?
 
Hello, sorry if this is off subject, does anyone know how to access the advanced settings or is there a manual on this. When riding in a group, i can't maintain a steady speed with pedal assist without stop and start pedaling. Thank you
 
Same issue here. Not acceptable at all. Waiting for them to send me a new controller.

Will look into the velcro idea posted earlier but that compartment where the controller sits is so tight I'm not sure how it will fit

I'm not very handy so can someone please advise how a protect the wires (do I just wrap them in the black electrical tape?)

Thank you all for helping. So frustrating to deal with this
 

Attachments

  • 16623498901557348402298305048343.jpg
    16623498901557348402298305048343.jpg
    78.1 KB · Views: 267
Two tesgo with same issue. Tesgo sent me 2 new controller. Once changed for new one it now appears the short affected the motor. Anyone else with this issue?
Update: tesgo sent wires, then motor and nothing fixed it. faulty wiring from factory fried the bike. 4 minths of emails back and forth, whole summer without a bike. November they now arrange for me to drop off the bike at a shipping warehouse and pick up a new one. When i get there the room has Many tesgo return bike boxes waiting to be shipped back. Not a good sign. What finally made them decide to send me a new bike? Not my polite emails but the bad review i put on their website, took only 12 hours to finally get a resolution. Have not tried the new one yet, will make sure to fix wire first thing but got 4 emails from tesgo asking me to change my review for a better one. All this to say a bad review seems to be the way to go.
 
Update: tesgo sent wires, then motor and nothing fixed it. faulty wiring from factory fried the bike. 4 minths of emails back and forth, whole summer without a bike. November they now arrange for me to drop off the bike at a shipping warehouse and pick up a new one. When i get there the room has Many tesgo return bike boxes waiting to be shipped back. Not a good sign. What finally made them decide to send me a new bike? Not my polite emails but the bad review i put on their website, took only 12 hours to finally get a resolution. Have not tried the new one yet, will make sure to fix wire first thing but got 4 emails from tesgo asking me to change my review for a better one. All this to say a bad review seems to be the way to go.
 
The answer was the controller inside the bike frame has a nick in the wires and shorted out. They sent a new controller.
Hi, question for you how long did it took before you received the part? I'm curious because I just submitted a claim and it's been a week I haven't received any news.. Thanks
 
Back
Top