500 watt sutto bafang motor with VCSV126-017-48T

njjane

New member
Local time
5:18 PM
Joined
Dec 19, 2022
Messages
3
I recently had this install on my bike. The place I purchased from on Amazon if really of no use to resolve it :(

500 watt sutto bafang motor with C-WKD4818A-LS-T-1 controller and DPC 18 display.

I am having an issue with the PAS systems.

On PAS 3 - PAS 1 and 2 did nothing , did not work not matter how fast or slow I pedaled , PAS 3 took off very fast

On PAS 5 - PAS 1 and 2 did nothing , did not work not matter how fast or slow I pedaled , PAS 3,4 & 5 took off very fast, but no real change in speed between them.

On PAS 9 - PAS 1, 2, 3,4,5,6 did nothing, PAS 7,8,9 took off very fast, but no real change in speed between them.

Attached are pictures of hub and controller.
 

Attachments

  • Rear hub1.jpg
    Rear hub1.jpg
    184 KB · Views: 81
  • Rear hub2.jpg
    Rear hub2.jpg
    199 KB · Views: 84
  • Controller.jpg
    Controller.jpg
    175.2 KB · Views: 83

sylwesterr

New member
Local time
11:18 PM
Joined
Jul 30, 2023
Messages
2
Location
Poland
Wow, I just joined the forum, checked this section and immediately found someone having the same motor with the same controller and even the same display... I have front hub motor kit, exactly the same-type controller, however there are minor differences - beginning of the serial number states the manufacturing date (mine is from Oct 10th, 2022, however purchased in May this year), and the low protection voltage is 42V, all other data is the same. I assume you are using it with 48V battery?
 
Top