Giant 2017 Full-e help

AnthonyDevon

New member
Local time
2:12 PM
Joined
Aug 17, 2023
Messages
1
Location
Devon
Hi, after years of faultless commuter riding I put my battery in this morning and the screen flashes on for a second but then switches off. Battery button says battery full and I think I've done the battery diagnostic right and it appears ok.
Can anyone shed light on what this might be? I'm lost without my bike. Can't walk far due to a back injury and this is my lifeline to the outside world.
 
With a removable battery, a common cause of issues are the contacts on the battery, or the mount, or the wiring from the mount to the controller.

Also look for a loose plug or damaged wire, especially if it fell over or had a crash or other impact event.
 
Hi, after years of faultless commuter riding I put my battery in this morning and the screen flashes on for a second but then switches off. Battery button says battery full and I think I've done the battery diagnostic right and it appears ok.
Can anyone shed light on what this might be? I'm lost without my bike. Can't walk far due to a back injury and this is my lifeline to the outside world.
Hi Had the same problem .After replacing ride control display and cables, still the same.it turned out to be the circuit board in the yamaha motor on my Giant Full-E+2 2017 MY. I was recommended to clean all connectors and spray with WD40 and wire connectors, and spray the circuit board with WD 40 contract cleaner . Re -Assembled motor and switched on. now working great. up to now still working for 20 days. Display and cables returned. just cost me £20.00 for 2cans of WD40.
Barry Kirkham (UK)
 
Back
Top