Turbo Levo Expert - Red Light on Battery All The Time

CharlotteFlyer

New member
Joined
Jul 30, 2020
Messages
2
Points
1
Hi,

I just bought a Turbo Levo Expert demo from my LBS. I looked at it a long time and finally pulled the trigger today. The bike is in great shape, but there is one thing I am wondering about, but its probably just something I can't find in the manual.

The last light on the battery (last 10 percent I guess) is always read, even when everything else is green. My understanding is that as the battery goes down by 10 percent increments, a green light goes out until the last 20 percent where the last two turn red. What could be causing this light to stay red all the time? Bike seems to be working fine, and no alerts in the app, but I can't find anything about why its red. I will say the battery is at 95 percent health as its been charged 50 times.

Any thoughts?
 
Last edited by a moderator:

ddockray

New member
Joined
Jul 30, 2020
Messages
1
Points
1
My guess is that the battery has ten zones and each zone is measured and balanced by the microprocessor in the battery, maybe your last zone is fading and is having trouble being recharged to 100%. I have heard people who say the lights can change and i think thats the zones fading and then being rebalanced but i really don't know. i would try riding the bike till the battery is absolutely drained then give it full charge and see where your at.
 

trlrdr

New member
Joined
Jul 26, 2020
Messages
2
Points
1
Hi im having trouble eith my levo the battery has 8 green lights and the last 2 im guessing 9 & 10th lite is #9 red & 10th is yellow and my bike is not running at all it ran a few minutes last time i rode it and then just stopped working anyone else see this problem ? i cant get any info on my mission control app its blank im not sure how to try to reset it . Ive got about 60 charging cycles on the battery so theres plenty of cycles left. Help !
 
Last edited by a moderator:

weeman32

New member
Joined
Jul 30, 2020
Messages
2
Points
1
I’ve had similar issue recently. I’ve got 3 flashing red lights on my Levo battery. Any ideas what this means? Looks like The dealer will replace the battery however have been waiting quite a while. Love my bike and recommended it to lots of friends who have purchased bikes. A bit pissed to be suffering these issues but hey ho.
 

Giant Warp

Member
Joined
Jul 19, 2020
Messages
64
Points
6
Usually a firmware bug. Get the firmware updated first. Do not replace the battery without trying that first.
 

Apiquip

New member
Joined
Jul 30, 2020
Messages
1
Points
1
Yep I have a similar issue on one of my batteries. So far hasnt affected its performance, slightly irritating however.
 

Giant Warp

Member
Joined
Jul 19, 2020
Messages
64
Points
6
So just a guess here, but just because the firmware is up to date doesn't mean the firmware doesn't have a bug. I have the lowest level of battery on a 2017 and it's firmware is 4.22.3.
 
Top Bottom