Trek FX+2 died

Entropy1024

New member
Local time
6:08 AM
Joined
Mar 27, 2023
Messages
2
I have a one month old Trek FX+2 that died this morning.

It had a full charge and I was out riding to work and around 4km into my commute the assist died and all the LEDs on the handlebar controller went out. I turned it back on and got 5 green LEDs, then when I pressed the plus button to up the assist level from zero to two, all the light went out again. The same thing happened again the next time I tried to turn it on. Now every time I try to turn it on nothing happens, no LEDs at all.

When I got to work I placed it on charge to see if that would reset anything. However again there were no lights on the handlebar controller.

Has anyone else experienced this and know what may be wrong and how to fix it?

Many thanks for any help.
 
Hey, did you find this post in hopes of solving a problem YOU are having? Well, unfortunately, the OP did not give a crap about helping anyone but themselves, and so never bothered to post back with the end result of how he solved his problem.

Remember to update.
 
Back
Top