Torque sensor issues - Genze E222B

sojourner

Member
Local time
2:02 AM
Joined
Dec 1, 2020
Messages
47
Points
8
I have a Genze E222B made for the Ride-Share program. It uses a crank arm torque sensor. Shifting to a higher gear causes the motor to deactivate for 3 seconds. However when starting from a stop; there is minimal lag. What could cause this?
 

kosciuk

New member
Local time
1:02 AM
Joined
Nov 18, 2022
Messages
2
Points
1
Hi there, did you connect the output of the torque sensor to the PAS connector on the controller or directly to the throttle?

Did you need to program the controller with your display, or maybe a Cycle Analyst display, or maybe a computer or phone?
thanks for any info. I want to replace the cadence sensor on my bomber frame to a torque sensor.
 

sojourner

Member
Local time
2:02 AM
Joined
Dec 1, 2020
Messages
47
Points
8
Hi Kosciuk; Thanks for replying to my old post. The bike, Genze (rideshare built) evidently has both cadence and torque sensors. It seems that the sensors work against each other at times.
As far as your inquiry on wiring...I just hooked them up as to the instructions. The bike has no readout, no `multiple assist level, and no readout. Altho I have had alot of training in electronics; it was long ago...Probably; due to my advanced age, I have not been able to disconnect the julet connectors. (the bike has a wiring harness which has cables (not used on this model) so it's possible I misconnected something.
 

kosciuk

New member
Local time
1:02 AM
Joined
Nov 18, 2022
Messages
2
Points
1
Thanks Sojourner, I've got a Genze crank arm torque sensor this tuesday. I'll let you know if I get it working. I guess the first thing to try will be connecting to the PAS line on the controller, next I'll try the throttle line.
 

Jeffb

Member
Local time
1:02 AM
Joined
Jul 17, 2022
Messages
37
Points
8
What's the output from a torque sensor? Is it a variable resistance or increased voltage when applying pedal force?
Either way I don't see how hooking it to the pas will work as the pas is a digital on off on off signal when the magnets cross the sensor.
Hooking the torque sensor to the throttle makes more sense.
Throttles work by passing more voltage as you twist or push the lever. If the torque sensor passes more voltage with increased torque it kind of works the same? I might need a bit of schooling.
 
Top Bottom