Shimano XT di2 shift issues

Booher

New member
Joined
Jan 3, 2022
Messages
2
Points
3
I have 2018 Pivot Shuttle with Shimano XT di2 setup. Recently the bike started not shifting consistently, instead beeping. after a few jabs it would shift. This condition progressively worsened to the point it will not shift or display the gear position. I have checked all di2 tube connections, swapped di2 cables, completed RD reset, updated to the latest software, done a derail check. On the stand we can get the bike to go thru all of the gears but as soon as a person puts a load on the bike it stops shifting. Pivot and Shimano have not been able to help other than to say take it to a dealer. I am using the dealer tech to do all the updates already. Next step is component replacement starting with the shift switch, derailuer and computer. Bike has 4600 miles.
 

Hoggdoc

Active member
Joined
Mar 5, 2021
Messages
376
Points
28
Location
Longview, WA.
Website
activityphoto.com
I have 2018 Pivot Shuttle with Shimano XT di2 setup. Recently the bike started not shifting consistently, instead beeping. after a few jabs it would shift. This condition progressively worsened to the point it will not shift or display the gear position. I have checked all di2 tube connections, swapped di2 cables, completed RD reset, updated to the latest software, done a derail check. On the stand we can get the bike to go thru all of the gears but as soon as a person puts a load on the bike it stops shifting. Pivot and Shimano have not been able to help other than to say take it to a dealer. I am using the dealer tech to do all the updates already. Next step is component replacement starting with the shift switch, derailuer and computer. Bike has 4600 miles.
Maybe this video will help you fix your issue:
 

Booher

New member
Joined
Jan 3, 2022
Messages
2
Points
3
Found the issue. Pivot Shuttle runs the Di2 off the motor battery. We suspected a bad di2 tube and sure enough the wire running from the motor to the derailuer thru the rear triangle had snagged something pulling the wire and the rough edge of the carbon frame cut the wire. You have to drop the motor to get to it and so it was an all day project. Poor design by pivot which was corrected on the second gen model. I cleaned up all of the wiring routing and put some shrink tubing around the wire and spots where the wires are secure to the carbon frame. Will also tape the derail wire where it comes out of the triangle as it is easily snagged when bushwacking. Of course it was the last and hardest spot to check.
 

Hoggdoc

Active member
Joined
Mar 5, 2021
Messages
376
Points
28
Location
Longview, WA.
Website
activityphoto.com
Found the issue. Pivot Shuttle runs the Di2 off the motor battery. We suspected a bad di2 tube and sure enough the wire running from the motor to the derailuer thru the rear triangle had snagged something pulling the wire and the rough edge of the carbon frame cut the wire. You have to drop the motor to get to it and so it was an all day project. Poor design by pivot which was corrected on the second gen model. I cleaned up all of the wiring routing and put some shrink tubing around the wire and spots where the wires are secure to the carbon frame. Will also tape the derail wire where it comes out of the triangle as it is easily snagged when bushwacking. Of course it was the last and hardest spot to check.
Glad you found the issue. So it was a power/communication issue I kind of figured it had to be something like that.
 
Top Bottom