Riding my M2S R750

jimmy

New member
Joined
May 11, 2020
Messages
4
Points
1
Just out for a light ride on my MS2 R750. My M2S R750 has been averaging 50 to 60 miles on the rail trail using PAS 1 and 2 with 2 bars showing on battery indicator..rarely use throttle..just to cross intersections.. have 300 miles with no issues..
MS2 R750 ebike.jpg
 

gary

New member
Joined
May 5, 2020
Messages
6
Points
1
I’m about 300 miles myself right now and only had to change a rear tube. Love the bike, except the seat.
 

jimmy

New member
Joined
May 11, 2020
Messages
4
Points
1
My friend suggested getting a air pump and tire repair kit, since we can travel farther especially on off road trails being so far out would be a walk and a half..
 

Craig

New member
Joined
May 11, 2020
Messages
3
Points
1
Unfortunately I’ve had several problems with my am M2S bike. The tires are so thin that I got seven flats in two days. Spent $60 on tire liners and slime in the inner tubes and have not had a problem since. 2nd Problem was the spokes were extremely loose out of the box causing the whole bike to wobble. Spent $60 at a bike shop to have them both properly tightened. After only 50 miles of riding the throttle stop working and the speed sensor stopped reading as well. The pedal assist still works so I continued riding with no speedometer or throttle. They sent me a new sensor but it didn’t solve the problem. They had me take it to a bike shop and they could not figure out the problem. I got the bike back and went for a ride and within 200 yards sparks started flying out of the throttle control and the whole thing went dead. I have been waiting over 10 days for them to ship out a complete new wiring harness. They said if that doesn’t work they will give me my money back. This is been extremely frustrating. When the bike was working I really love it. Not so sure I would buy another bike online as it is difficult to find a shop to work on it.

--- UPDATE --- The wiring harness arrived today and they’re putting it in. Fingers crossed should know in the morning.

--- UPDATE 2 ---The wiring harness arrived and did not solve the problem. I think we’re looking at a whole new motor at this point. So frustrating because I was so excited about riding and now I’ve missed almost a month and still not fixed.
 

gary

New member
Joined
May 5, 2020
Messages
6
Points
1
Sorry to hear about your bike Craig, I took a chance like yourself the reviews were hard to ignore..guess like buying a car or anything else there are lemons. I really have not taken my bike on any rough trails, kind of worried about the electronics. But have taken it on some off road trails and so far it has been fine. Have to keep us posted how you make out with your bike..hope you are able to get it fixed and up and running....
 
Top Bottom