Repeated Power Cut Issue with Tesgo STT E-Bike Battery

antenando

New member
Local time
7:12 PM
Joined
May 19, 2024
Messages
1
Location
Montreal
Hey everyone,

I've been having an issue with my Tesgo STT e-bike, and I'm wondering if anyone else has experienced this. During my recent 33km ride, the power cut off while the battery still showed 30% remaining. This has happened four or five times now, and it's starting to get really frustrating. Luckily, I was only a block away from home this time, but still.

A few details:
  • The battery was fully charged before the trip.
  • The weather was moderate, not hot or cold.
  • The battery was showing 30% charge before the power cut.
Has anyone else had this problem? Is it normal for the power to cut off when the battery still indicates 30%? Any tips on what settings or maintenance I should check? Could it be a firmware issue that needs updating? Or maybe the battery needs recalibration or replacement?

I'd really appreciate any advice or solutions you can share. Thanks!

Fernando
 
Most likely your battery is getting towards the safety voltage cutoff for low battery level. Once the voltage drops to the cutoff, it shuts your battery down. Are you able to see the battery voltage, or does your controller show something like power bars? On some bikes you an change this setting, on others you can't. Mine starts doing the same thing once my battery gets to about 50V. It depends on how much energy you are trying to pull from the battery.

Usually controllers shut the system down somewhere in the 41-44V range. Next time it happens you can turn down the pedal assist and you may be able to ride a few more miles.
 
Back
Top