Rear Hub Motor Making Weird Noise

UniversalModder

New member
Local time
12:05 AM
Joined
Dec 1, 2020
Messages
2
Hi guys I have a problem that just began today my rear hub motor is making a weird noise whenever I try to give it some power not sure what's causing it, I tested all the cables from the controller and nothing seems to be wrong not sure if anyone could help thanks in advance. Here is a link to the video that shows the noise.
 
Last edited by a moderator:
Most hub motors are geared. Meaning they have a planetary gearset to allow the motor to spin faster than the wheel. Chances are one of those planet gears is messed up or lacking grease. Time for disassembly, either by you or your LBS.

Cheers.
 
Hi i opened up my motor and I can't seem to find anything wrong with it i'm still not sure what's making the noise i took some photos if you would like to see anything i don't notice
 

Attachments

  • inside ebike hub motor01.jpg
    inside ebike hub motor01.jpg
    50.9 KB · Views: 442
  • inside ebike hub motor.jpg
    inside ebike hub motor.jpg
    60.6 KB · Views: 882
Last edited by a moderator:
I'm having the exact same issue, but only on extremely steep slopes. Do you get power spikes on your hud when it's making these noises?
 
Hi guys I have a problem that just began today my rear hub motor is making a weird noise whenever I try to give it some power not sure what's causing it, I tested all the cables from the controller and nothing seems to be wrong not sure if anyone could help thanks in advance. Here is a link to the video that shows the noise.
 
Hi guys I have a problem that just began today my rear hub motor is making a weird noise whenever I try to give it some power not sure what's causing it, I tested all the cables from the controller and nothing seems to be wrong not sure if anyone could help thanks in advance. Here is a link to the video that shows the noise.
Hi did you sort the problem if so what was it
 
Yes I’m have this issue too, mine is stiff as well as noisy. I opened it up but I don’t think there are any gears in the voilamart 1500w rear hub motors-?
 
That looks like a direct drive motor from the photos but it's hard to tell. The planetary gears should be quite obvious so if you don't see them I'm thinking no. As for the noise i've no idea. I would take it to an ebike mechanic, someone who works on hub motors.
 
Back
Top