Rad City Won’t Power On

jstewar9

New member
Local time
1:27 PM
Joined
Mar 15, 2023
Messages
1
Hey folks - I have a Rad City that no longer powers on. Here’s what I’ve tried so far:

* went through all RadPower troubleshooting guides/videos to check wires - found no issues
* bought a replacement controller - also doesn’t power on
* borrowed a friend’s battery - also did not power on

So I know it’s not the battery or the controller, but not sure what else to try. Maybe the battery mount/connector, but not really sure how to test that. I also haven’t found a local shop that will look at the electrical components.

For context, I used the bike pretty consistently for about a year up until COVID lockdowns. It was in storage during lockdown and then I was able to use for about a month before this issue popped up.

Any thoughts?

Cheers,
Jonathon
 
What sort of on/off switch does the bike have e.g. press switch on the battery, a key press on the display, etc.?
 
Hey, did you find this post in hopes of solving a problem YOU are having? Well, unfortunately, the OP did not give a crap about helping anyone but themselves, and so never bothered to post back with the end result of how he solved his problem.

Remember to update.
 
Back
Top