Pace 500 Controller Screen failure

Mike Ellis

New member
Joined
May 10, 2021
Messages
3
Points
1
Started out on a ride today. After 1/4 mile, the motor stopped and the LCD screen went blank.
  • Battery is freshly charged and shows 4 bars lit.
  • Tried turning the battery off and back on multiple times.
  • Also removed the battery, checked the internal connector, and re-inserted the battery several times.
  • Unplugged and replugged all the in-line connections.
  • LCD will not come on no matter how long I hold the start button down.
The bike was purchased from Aventon not quite 2 years ago. I've got about 1900 miles on it. It's ridden regularly and kept in a garage when not in use.

Are there any other diagnostic steps I should try? If the controller is dead, how long and how much to get a replacement?

Thanks!
 

Mike Ellis

New member
Joined
May 10, 2021
Messages
3
Points
1
It's been 3 days and no response from Aventon (beyond a robo reply when I posted the above on their support page).

When I bought the bike 2 years ago, I gave them a 5 star review for the overall quality of the bike and their outstanding initial support with a couple of minor issues. I've recommended the bike to everyone who's asked about it.

Sad to say that rating is falling rapidly. The only thing they could do at this point to get back to 5 stars is to call me up, apologize for the delay and rush ship a replacement display at no charge.
 

Mike Ellis

New member
Joined
May 10, 2021
Messages
3
Points
1
So it's now 11 days and counting. I had some correspondence with Aventon support. It was friendly but not really useful since they offer no remote diagnostic capabilities, manuals, schematics or troubleshooting procedures. The nearest Aventon dealer is 200 miles from me.

We've an excellent local shop (North Star Sports) here in Burlington VT that specializes in e-bikes. They took a look but were unable to come up with definite diagnosis. They sell the high-end bikes with Bosch mid-drives and, lacking access to technical data from Aventon, weren't able to do much more than I could (but at least they tried!)

So I'm down to ordering a replacement display from Aventon and hoping that is indeed the failed component.
 
Top Bottom