Need some help please (M866S display)

Steve Perry

New member
Joined
Feb 5, 2022
Messages
26
Points
3
Hi, I have been sent a MorNon 48v 1500w rear motor kit which I have fitted to my mountain bike.
The kit came with no instructions so I was wondering if anyone can tell me how to set the display, the only number written on it is
M866S .
I look forward to hearing from you.
Regards
Steve Perry
 

rogerclark

New member
Joined
Feb 5, 2022
Messages
16
Points
3
I can't directly help steve, but I'm in a similar position.

My bike has a display labelled S2 and I can't find much data either


Can you post a link to the online listing for your kit showing a photo of the display, as people may recognise the real model number of the display
 

Steve Perry

New member
Joined
Feb 5, 2022
Messages
26
Points
3
31032407-D869-4593-98E4-0D67C25395CE.jpeg
7B56C69C-04DC-4A64-A6CA-2843B35307A8.jpeg
 

Steve Perry

New member
Joined
Feb 5, 2022
Messages
26
Points
3

rogerclark

New member
Joined
Feb 5, 2022
Messages
16
Points
3
What do you mean by "Set the display"

Do you mean you've not connected it etc ?

Or do you mean the menus on the display?
 

Steve Perry

New member
Joined
Feb 5, 2022
Messages
26
Points
3
I mean the menus on the display.
I have held down the up and down buttons and have got into the menu but I don’t know what to set each option to.
 

Steve Perry

New member
Joined
Feb 5, 2022
Messages
26
Points
3
Many thanks for the info.
It looks like the position settings are the same.
I was wondering if you use this display?
I have set the following
P3 - 52v
P10 - 1 for throttle only
P14 - 10

Is this what you set yours to?
I am using a 52v battery with a 1500w motor.
I look forward to hearing from you.
Regards
Steve
 

HumanPerson

Moderator
Staff member
Joined
Jan 21, 2021
Messages
511
Points
43
mine are as follows:
P3= 52
P10= 1
I dona have the PAS hooked up so cant help ya with P14.
 

Steve Perry

New member
Joined
Feb 5, 2022
Messages
26
Points
3
Thank you for the information
Did you use the guide you sent me for the sw900 display or is yours a different display. I don’t have pas either.
 

HumanPerson

Moderator
Staff member
Joined
Jan 21, 2021
Messages
511
Points
43
Yep, my 1500W hub drive Voilamart kit came with the SW900.

I never hooked PAS up to it so it's all throttle. Yep, i used the guiides i pasted here for the settings
which i just tweaked around till i got what works for me the best.
 

Steve Perry

New member
Joined
Feb 5, 2022
Messages
26
Points
3
Try the settings for the SW900 display and see if they work on yours.
Yep, my 1500W hub drive Voilamart kit came with the SW900.

I never hooked PAS up to it so it's all throttle. Yep, i used the guiides i pasted here for the settings
which i just tweaked around till i got what works for me the best.
Thanks for your reply, please could you tell me what setting you use for P 14 (current limit)
Regards
Steve
 

Steve Perry

New member
Joined
Feb 5, 2022
Messages
26
Points
3
Many thanks for the info.
I am new to all this!
I know it’s a big ask but maybe you could post the rest of your settings so that I can copy them and it might help others.
 

HumanPerson

Moderator
Staff member
Joined
Jan 21, 2021
Messages
511
Points
43
Many thanks for the info.
I am new to all this!
I know it’s a big ask but maybe you could post the rest of your settings so that I can copy them and it might help others.
P01 - light dimmer.. i leave bright.
P02 - 1 for mph not kph
P03 - mine goes up to 72v so right now it is set at 52v
P04 - i keep on 0
P05 - I dont have PAS hooked up so this means nothing at this time.
P06 - 26
P07 - I dont have PAS hooked up so this means nothing at this time.
P08 - mine is set at 100 = No Limit
P09 - 0
P10 - 1 (No PAS hooked up so this means nothing at this time)
P11 - I dont have PAS hooked up so this means nothing at this time.
P12 - 0
P13 - mine has 12 but I dont have PAS hooked up so this means nothing at this time.
P14 - Sometimes i adjust the current limit from 14 for flat ground runs up to 20 for hilly runs.
P15 -31.5 - 41.5 (Your display, even though M866S display, it seems like an older version of SW900 which does not use this at this time.)

 

Steve Perry

New member
Joined
Feb 5, 2022
Messages
26
Points
3
Thank you very much for doing that
I really appreciate it.
I will give it a go at the weekend and let you know.
Regards
Steve
 
Top Bottom