M866S Display not working

LCDDisplayHelp

New member
Local time
3:09 PM
Joined
Aug 8, 2022
Messages
6
Hi, today I was riding my bike and the LCD display turned off but the bike was still going - I immediately went home and checked the cables, the fuse holder was completely melted, so I've changed that..

However the bike needs the LCD display turned on to move, but the LCD display will now not turn on.

The fuse is working because the throttle light turns on but all of a sudden my LCD display will not turn on.

What could this mean? is the LCD display broken or could it be the controller?
 
Hey, Welcome to our humble home, by the way :)
Hi, thanks :D..

Do you by any chance have any knowledge with this stuff?

Everything works when i've replaced the fuse but the LCD display is the only thing that doesnt work. it was a 35a fuse but I replaced with a 30a fuse
 
Hi, thanks :D..

Do you by any chance have any knowledge with this stuff?

Everything works when i've replaced the fuse but the LCD display is the only thing that doesnt work. it was a 35a fuse but I replaced with a 30a fuse
Heya mate :)

Well ima not to savvy on most things but we can dig for answers together :)

I'd have gone with the 35a fuse. I'd try another Display. Something could have shorted so look at all the wires coming from the fuse
where you said it originated from.

Bike brand? Like what ya ridin? We know nothing until we get deets ;)
 
Heya mate :)

Well ima not to savvy on most things but we can dig for answers together :)

I'd have gone with the 35a fuse. I'd try another Display. Something could have shorted so look at all the wires coming from the fuse
where you said it originated from.

Bike brand? Like what ya ridin? We know nothing until we get deets ;)
It was an unbranded kit, I put it together and has worked good for around 2000 miles, the fuse was melted but hadn't blown as everything was still working apart from the LCD display, the new fuse is working as the throttle is getting power, the only thing now not working is the LCD display but it has to be turned on to give the bike power.


I've unplugged the lcd display and plugged it back in a few times - all looks fine with the wires
 
And be sure to check your plug in coneections
I think my next step is to buy a lcd display with the same connector as i cannot find my current one online, I cant imagine anything is wrong with the controller as the throttle is working (the lights turn on when switched on)

There isn't a fuse in the lcd display separately so i don't see how the lcd display could have broken randomly, but im starting to think it has to be something with the display as that was the one part that gave me issues prior to me seeing the fuse
 
Link to the kit so we can see what ya have, yeah mate that could have just made the display weird out, just a sudden surge , milliamps, will brick a display. Any pics of your display and more info on what you have mate.
 
Should be some others chiming in here. I'm gonna go get some family time then hit the sack,
I think you'll get some answers mate :)
 
7B56C69C-04DC-4A64-A6CA-2843B35307A8.jpeg

Link to the kit so we can see what ya have, yeah mate that could have just made the display weird out, just a sudden surge , milliamps, will brick a display. Any pics of your display and more info on what you have mate.
This is the display I have, as for the rest of the kit, the sale link isnt available anymore, it was all unbranded
 
Back
Top