M620/G510 burnt controller issues

said

New member
Local time
11:32 AM
Joined
Feb 1, 2023
Messages
4
Hi there, I have a burnt controller on my M620/G510 Ultra. Everything was fine, and I was enjoying my rides with it. Last October, on a local ride after a bigger bunny hopp the whole bike went dead. Pushing out of the valley and back home was a great workout with a double battery setup...
Thinking it was the controller itself, I order a new one (4 month shipping). After putting it back together and connecting all the cables, nothing happened. I then realised i forgot the display plug. UART green rounded plug. As i plugged it in, there was a little spark at the plug and a loud pop from the motor below. The result is a 2nd dead controller. It burned out exactly on the same spot where the prev. original controller.
Does anybody have or had similar issues before?
Thanks.
Said
 

Attachments

  • 20230127_165734.jpg
    20230127_165734.jpg
    240.5 KB · Views: 110
  • 20230127_165740.jpg
    20230127_165740.jpg
    218.7 KB · Views: 112
  • 20230127_165744.jpg
    20230127_165744.jpg
    191.3 KB · Views: 98
  • 20230127_165801.jpg
    20230127_165801.jpg
    223.9 KB · Views: 107
I have had my M620.G510 Ultra since APR 2021, about 800 miles ridden on it zero issues.
But it would be interesting to follow this thread and learn more details.
 
It might be that I was too hard on the bike.
This was one of my first ride with it. And I blow the shock on it at the end, :D I did something similar when it died.
 
It might be that I was too hard on the bike.
This was one of my first ride with it. And I blow the shock on it at the end, :D I did something similar when it died.
Welcome to the forums :cool:
 
Check any places wires could have pinched....
Thanks! It is difficult with this frame and a double battery setup. I could not find anything, but I did not pull out all the way the wiring from the down tube
 
Update. I found a suspect wire. It looks too clean for me tho.
 

Attachments

  • 20230203_121207.jpg
    20230203_121207.jpg
    90.1 KB · Views: 103
  • 20230203_121507.jpg
    20230203_121507.jpg
    162.7 KB · Views: 101
  • 20230203_121527.jpg
    20230203_121527.jpg
    148.5 KB · Views: 107
I am newer to ebike repairs. I have a G510/M620 Bafang motor, I regreased the motor and put back together and one wire pinched, I was able to start and ride it, after shutting off it wouldnt start again. I could use some advice on if you think it is just the controller or if I need to replace display or anything else same time. I dont want fry new parts by not replacing everything needed.
 
Back
Top