Jetson Bolt Pro power goes off when turning

highgravity

New member
Joined
May 9, 2022
Messages
2
Points
1
Had the bike for 6 months, and very happy. Newbie here.
Son came home and complained that when turning left, the power lights would go off and the motor would cut out. Even a slight deviation left from straight caused this issue.
Took the cover off and pulled each of the cables separately (I assumed there was a kink or something)...no dice.
Any thoughts?
TIA
 

Hoggdoc

Moderator
Staff member
Joined
Mar 5, 2021
Messages
503
Points
43
Location
Longview, WA.
Website
activityphoto.com
Sounds like you have a broken wire somewhere near the steering head. If you have a meter and know how to check continuity the wires feeding the display that would be a start.
 

Lillian

New member
Joined
Jul 29, 2022
Messages
5
Points
1
Had the bike for 6 months, and very happy. Newbie here.
Son came home and complained that when turning left, the power lights would go off and the motor would cut out. Even a slight deviation left from straight caused this issue.
Took the cover off and pulled each of the cables separately (I assumed there was a kink or something)...no dice.
Any thoughts?
TIA
The same thing happened to me but it was when I turned right. I don’t know how to fix it thoug.
 

Hoggdoc

Moderator
Staff member
Joined
Mar 5, 2021
Messages
503
Points
43
Location
Longview, WA.
Website
activityphoto.com
That was my first thought, and yes. But it's not just the display, it's actual drive/power
I would look at battery connections in that case. Although that doesn't make sense why it would lose power when turning the handlebars. I'm still thinking it has to be something at or near where the wires are at the steering head.
 

Lillian

New member
Joined
Jul 29, 2022
Messages
5
Points
1
Had the bike for 6 months, and very happy. Newbie here.
Son came home and complained that when turning left, the power lights would go off and the motor would cut out. Even a slight deviation left from straight caused this issue.
Took the cover off and pulled each of the cables separately (I assumed there was a kink or something)...no dice.
Any thoughts?
TIA
I have the same thing but with turning right
I think maybe it needs new wires but I still don’t know.
 
Top Bottom