Huge sparks when turning in battery at controller connection

hurtenum

New member
Local time
5:33 PM
Joined
Jan 23, 2023
Messages
3
Points
1
I have a bbshd with a 52v 17.5ah battery. The other night I plugged it in to charge. The next morning I came out and the charger was blinking between green and red and the display wouldn't turn on. The battery is reading a full charge from the bms and everywhere else. I put new xt90 connector on the battery and the controller. When I plug into the controller and turn the battery on I get a huge spark that melts the metal on the positive of the connection. All connections from the controller to other source e.g. the display, throttle and whatnot are all fine. What would cause this and where should I start. Thank you for your time.
 

HumanPerson

Ooohhhmmmmm
Staff member
Local time
5:33 PM
Joined
Jan 21, 2021
Messages
1,468
Points
83
Oh that doesn't sound good.

"turn the battery on I get a huge spark that melts the metal on the positive of the connection."

Sounds like you have a dead short somewhere. Are ya sure ya put the XT90 connectors on correctly? Has the battery been dropped?
I hook up a 52v 40ah battery to my bbshd and get a crazy spark all the time, but nothing melts.

Welcome to the forums by the way :cool:
 

hurtenum

New member
Local time
5:33 PM
Joined
Jan 23, 2023
Messages
3
Points
1
Positive I put it in right. Haven't dropped it or had any significant damage to it. It stays on my downtube and the bike hasn't fallen over wither
 
Top Bottom