How to Fix Bafang BBSHD & BBS02 Error 30

subramanian0331

New member
Joined
Jun 2, 2021
Messages
1
Points
1
hey guys.. i am having the same problem with 30H error and PAS&Throttle working and no speed or Odo on the display.. I tried 2 different usb programming cable and still can't connect to controller.. (to reflash the firmware) any help is appreciated
 

Avery

New member
Joined
Jun 12, 2021
Messages
1
Points
1
Another annoying error code 30 problem. I'm new to this bafang motor set up so bear with me.
The speed sensor broke off after making contact with the spoke mounted doohickey. Obviously I had to ride home anyway. And I had to use it the following day. Everything worked as normal except lack of speedo as you would guess.
Now the display is showing error code 30, I have also removed the battery a few times whilst checking things. I'm confused as nothing else has changed. I've remounted the speed sensor but error code 30 still shows. It must be, if the world is logical but it isn't always, related to the speed sensor and riding without it??
Is there a way to say reboot... I'm wondering if I've upset it by riding without the sensor. It's really annoying. I've tried turning it on and off, I've tried wriggling wires and I've tried screaming at it.
Any other ideas?
 

praskavi

New member
Joined
Jul 9, 2021
Messages
3
Points
1
After checking MCU was able to set to 3.86. Flashed my controller and now can use 52 V batteries. Tried to re-flash Luna setup and got current out of range error and had to re-flash using the 'Golden' again cause error 30 was set. Will check few more things and maybe try again. Want the throttle not related to PAS settings. May even put the faulty controller on and try flashing it but think it has hardware fault slight electrical burn odor.

UPDATE - after flashing with the 48 to 52 flash everything is good except if I use Bafang Config Tool after doing a read, cannot write in fact I get error 30. so far only way to fix is to the complete flash again. I want to set the assist 0 values to 1 so the throttle will work independent of PAS. I tired both the Bafang Config Tool and the Stafan Penov version with same results am afraid try many more time fear of breaking the connector or something else. Any help or explanation? Is my controller locked and shuts down if try reading with the Config Tool?
Yes, I am also facing the same issue, after following step by step of the golden motor instructions, It looks like when u try to use Bafang Config tool, you can only read but cant write, the moment you try to change the settings, it looks like communication is failing..and again we need to flash the controller using the steps. How do we manage to change the settings after flashing the controller as per the golden motor video? Did you manage to figure out?
 

praskavi

New member
Joined
Jul 9, 2021
Messages
3
Points
1
After checking MCU was able to set to 3.86. Flashed my controller and now can use 52 V batteries. Tried to re-flash Luna setup and got current out of range error and had to re-flash using the 'Golden' again cause error 30 was set. Will check few more things and maybe try again. Want the throttle not related to PAS settings. May even put the faulty controller on and try flashing it but think it has hardware fault slight electrical burn odor.

UPDATE - after flashing with the 48 to 52 flash everything is good except if I use Bafang Config Tool after doing a read, cannot write in fact I get error 30. so far only way to fix is to the complete flash again. I want to set the assist 0 values to 1 so the throttle will work independent of PAS. I tired both the Bafang Config Tool and the Stafan Penov version with same results am afraid try many more time fear of breaking the connector or something else. Any help or explanation? Is my controller locked and shuts down if try reading with the Config Tool?
Yes, I am also facing the same issue, after following step by step of the golden motor instructions, It looks like when u try to use Bafang Config tool, you can only read but cant write, the moment you try to change the settings, it looks like communication is failing..and again we need to flash the controller using the steps. How do we manage to change the settings after flashing the controller as per the golden motor video? Did you manage to figure out?
 

Mac

New member
Joined
Jul 17, 2021
Messages
1
Points
1
Hi I have bafang 1000w 20ah batery I did only almost 500 km and I have error problem ( error 30 comunication fault ) motor is not working with pedal asistmant and is not working with pressing the botton and on my speedo is normaly red light on and now is off cann you help me semeone pls what to do ?
Please tell us did you figure it out yet because it is doing exactly what mine is doing and no red light and error 30H
 
Top Bottom