Ebgo CC48+ controls failure

Ronk

New member
Joined
Nov 18, 2020
Messages
2
Points
1
After working great for weeks, the Ebgo 48+ bike is now inoperative.
On power up the display lights up momentarily with the number 2072 in the lower left of the screen. The screen then goes blank except for 'Error' shown on the right side of the screen. The control buttons then do nothing except power off. The same repeats on further power on attempts. The barebones manual contains no error code info. To date there is no resolution with customer service and no hint of what the problem may be. I can return the bike under warranty but it is frustrating to reach this point.
Does this 2072 number make sense to anyone?
 

Ronk

New member
Joined
Nov 18, 2020
Messages
2
Points
1
Resolved. Display Replaced. Bike now operates normally.
Thr original display was a RoHS C600. The new replacement is the same. On power up of the new display the number 2072 also displays momentarily before normal bike operation resumes. I am told that the original display was irrevocably disabled and locked by my inadvertent simultaneous pushing of the 'SET' and '+' buttons on the display control. Go figure. I am not about ready to test the new display by pushing the same buttons simultaneously again.
 

Millo

New member
Joined
May 26, 2021
Messages
2
Points
3
error no screen ---> wait ~5 min screen will show 4 underscore marks _ _ _ _ , use +(1) or - (0) to enter code 1111 and screen come back to normal view and press "SET" for 3-5 sec and correct setting in the advance menu.
 

Thinksun

New member
Joined
Jun 13, 2021
Messages
1
Points
1
error no screen ---> wait ~5 min screen will show 4 underscore marks _ _ _ _ , use +(1) or - (0) to enter code 1111 and screen come back to normal view and press "SET" for 3-5 sec and correct setting in the advance menu.
Thank you Millo, I had the same issue as OP! However Everytime I turn the bike on I have to enter 1111 before I ride. I have held the set button 3-5 seconds and longer till I see SET in display where it doesnt let me do anything else. Would you know what I am doing wrong or need to do to get display to start without entering 1111?
 
Top Bottom