Can't get air into Rear Tire - Swagtron pro

justdon

New member
Local time
8:31 AM
Joined
Mar 25, 2023
Messages
9
I just bought a swagtron pro got it today put it together and charged it up put air in the front tire and no matter what i try i cannot get air in the rear tire i know this will sound stupid but but do you need some different type connecter to hookup and put air in.
 
thumbnail (21).jpg
 
It could be anything from a small hole somewhere on the tube or a split/hole aroind the valve stem or even check and be sure the valve
core is seated firmly/properly
 
While yur in there check and be sure that there are no sharp protrusions inside of your tire as well as around the bead area that touches the inner tube.
 
The connector does not seem to fit on the stem.A neighbor told me to get some adapters.
 
Oh, you just cannot get it on there then?
Yeah you'll need to find the right adapter to fit the valve then to your pump.

Keep us posted mate :)
 
That bend in the valve stem would appear to insure that no pump will be able to securly attach. Once again; Your LBS (local bike shop) is the answer.
 
Links to Amazon may include affiliate code. If you click on an Amazon link and make a purchase, this forum may earn a small commission.
I got the adaptor today put it on and went to a gas station and filled the tire it was hard and i thought iam good to go.I get home take off the adaptor and it seems like the tire is flat again i put the adaptor back on pump it up by hand seems good take off the adaptor again and flat again.Iam going to take it to an LBS tomorrow.
 
Took it to the LBS this morning.I told him what was going on.He said yea some valves need adaptors.he said but when i check it i will bet you have a defective tube.So sure enough he let me go in the back with him and when he took off the tube inflated it and dipped it in water air bubbles were coming from a few spots on the tube.So he ordered a new tube And he said he should have it by friday.So i will owe him 30 bucks.I called a few other places that wanted 75 or 100 bucks.
 
Took it to the LBS this morning.I told him what was going on.He said yea some valves need adaptors.he said but when i check it i will bet you have a defective tube.So sure enough he let me go in the back with him and when he took off the tube inflated it and dipped it in water air bubbles were coming from a few spots on the tube.So he ordered a new tube And he said he should have it by friday.So i will owe him 30 bucks.I called a few other places that wanted 75 or 100 bucks.
$30.00 isn't bad.
That $75 to $100 is way to much to put a tube onto a wheel into a tire on a swagtron pro..just sayin.
 
I think it was great of that shop to help you and $30 is cheap for the aggravation. I hope you support them in the future.
 
I just bought a swagtron pro got it today put it together and charged it up put air in the front tire and no matter what i try i cannot get air in the rear tire i know this will sound stupid but but do you need some different type connecter to hookup and put air in.
This may sound dumb, I bought a valve Core remove tool at wally world that was damaging cores bending the needle. Took me too long to catch that one. Same deal putting air in hard.
 
Back
Top