BBS02 500C display issue

the_deuce

New member
Joined
May 24, 2022
Messages
2
Points
1
My 500C display turned off mid ride and the bike died. I was able to charge the battery like normal to a full 57V. I see 57V using a multimeter at the cable going into the display. So seems the battery harness is fine. Thought for sure it was just a dead display but I ordered a new one, and that one won’t turn on at all either? Could it be something in the battery not allowing a current load to the controller display? Like a bad BMS?
 

the_deuce

New member
Joined
May 24, 2022
Messages
2
Points
1
Thanks BBassett. A new controller was my next guess. I believe the controller generates a +5V that passes up the cable harness whereas the battery voltage passes through. I don't see a 5V so definitely suspicious of the controller. Do you have a recommendation for new controller vendor? I see Luna Cycle has a 750W 48V controller upgrade for BBS02 as in link below. I have a 52V battery however. concerned it won't work with 48V controller.

 

HumanPerson

Moderator
Staff member
Joined
Jan 21, 2021
Messages
488
Points
43
I've been using btrpower 52v and 60v batteries on my bbshd with not a problem.
I have a BBS02 that uses a 52v 30ah battery with no problems, but the bbshd uses both the 52v 30ah and the 60v 45ah battery.

The newer eggrider display will allow up to 72v..early on they had problems with anything over 58.8v (a 52v battery) which have now (seemingly) been fixed.

Just have to be careful where ya get batteries from. Just my own experience.
 
Top Bottom