Aostirmotor S18 1500w Throttle Abnormal Error 20H (after I got it wet)

Makadog

New member
Local time
7:37 PM
Joined
Jun 2, 2022
Messages
1
Howdy. I'm new to the forum. I have had an Aostirmotor S18 1500w for about 10 months, it has about 2700 miles. Love the bike. They said not to get it wet, but I got it wet. Got caught in a rainstorm about a week ago. Five days later I got a throttle abnormal error. 20H. Bike tends to wanna go all by itself every now and then. Have had the error for three days now. I disconnected the throttle Cable, but still have the error showing. I can still ride the bike, as PAS works just fine to engage the motor. Throttle abnormal error was intermittent the first day, now relatively constant. I've checked the cables and connections and all seems well there. Don't know whole lot about these bikes yet, but my guess is it's the controller. Any advice? And where is the controller on this bike?

TIA—

Jonathan Cooper
Allen, Texas
 
Have same bike and same message after a disc screw ripped up my cable and I repaired it.
 
Unusual the error remains after dis-connecting the throttle. Have you completely shut down, unplugged the battery from the controller, then waited, then re-connected the battery? This is like re-booting a computer, often necessary to clear an error code.

As for where the controller is, you posted no picture, and no link, so I have no idea. Don't feel much like hunting for an obscure model, when the user makes no effort to help.
 
Howdy. I'm new to the forum. I have had an Aostirmotor S18 1500w for about 10 months, it has about 2700 miles. Love the bike. They said not to get it wet, but I got it wet. Got caught in a rainstorm about a week ago. Five days later I got a throttle abnormal error. 20H. Bike tends to wanna go all by itself every now and then. Have had the error for three days now. I disconnected the throttle Cable, but still have the error showing. I can still ride the bike, as PAS works just fine to engage the motor. Throttle abnormal error was intermittent the first day, now relatively constant. I've checked the cables and connections and all seems well there. Don't know whole lot about these bikes yet, but my guess is it's the controller. Any advice? And where is the controller on this bike?

TIA—

Jonathan Cooper
Allen, Texas
Did you ever find out where the controller is on the Aostirmotor S-17 e-bike? I have that very same bike, and cannot find a controller anywhere. The errors I am getting are “Error 08H” and “Error 20H”, but my bike will turn on, go for about five to 30 seconds, then everything shuts off. If you have figured out this problem, please email me. Argyle302@aol.com.

Thanks
 

Attachments

  • IMG_9161.jpeg
    IMG_9161.jpeg
    136.1 KB · Views: 18
  • IMG_9160.jpeg
    IMG_9160.jpeg
    129.2 KB · Views: 18
Looking at a picture of the S 18 I would hazard a guess that the controller is inside the box that is located at the lowest point on the bike under the crankset. Also a possibility about the throttle malfunction is water may have gotten inside the throttle assy.
 
Thanks for your reply and input. I bought another throttle component, put it on and had the same problem. The box underneath the crank case just has a large connector that I believe goes to the motor. Nothing else is in there

I did try and write the company that sold me this bike. They are not very good at customer service after the one year warranty ran out. But they “claim” that the controller is inside the 1,500 watt hub motor. I mean, it might be in there, I have no idea where else on the bike they could have put it. Could it be built inside the battery pack??
 

Attachments

  • IMG_8577.jpeg
    IMG_8577.jpeg
    252.9 KB · Views: 19
Back
Top