Anyone update Mahle x35 firmware themselves?

j ai changé la batterie remplacement par mahle sous garanti avec mise à jour , ajout de l écran et tout fonctionne correctement
 
Just to conclude this tale of woe: :)The replacement battery finally arrived from Mahle (£600!) and I fitted it yesterday with no problems, it's actually a fairly straightforward job if a bit fiddly to thread the cables through the frame. When I registered the bike with new battery on the My Smartbike App it now comes up as a Ribble Endurance SLe which is weird because it's a Hybrid ALe! I thought Mahle would have linked to the bike model information via Ribble? Anyway, the bike is now working again and I won't be updating any firmware again in the near future!

A shout out to the Mahle dealer and eBike supplier EcoMove in Bristol who were really helpful in checking out the bike (at no extra cost), supplying the new battery and giving me some tips on installing.
 
I suspect I will have to bite the bullet and replace the battery on my 2020 Orbea Gain F20 (Out of Warranty) weird figures are showing for the 'odometer' mileage etc' which were previously ok, the battery percentage appears ok and the system is operating ok at present. How were you able to link/register the new battery with the other electrical items and bike frame number ? You were impressed by EcoMove, did these people do that for you when checking out the bike, I have not contacted them as yet, the bike still operates ok and still usable as an ebike. Previously I have had the firmware updated ok by a local dealer in Wells (Scott) Mahle registered but they cannot access the Orbea Mahle Dealer App. Your saga was most informative and helpful so thank you for that !
A previous problem was never resolved by Orbea/Mahle, the F20 has both an iWoc One and Trio controls fitted which originally both able to select power settings, the One stopped doing this and only turned on/off to Green, I was told Firmware Update would sort it, it didn't !
 
I suspect I will have to bite the bullet and replace the battery on my 2020 Orbea Gain F20 (Out of Warranty) weird figures are showing for the 'odometer' mileage etc' which were previously ok, the battery percentage appears ok and the system is operating ok at present. How were you able to link/register the new battery with the other electrical items and bike frame number ? You were impressed by EcoMove, did these people do that for you when checking out the bike, I have not contacted them as yet, the bike still operates ok and still usable as an ebike. Previously I have had the firmware updated ok by a local dealer in Wells (Scott) Mahle registered but they cannot access the Orbea Mahle Dealer App. Your saga was most informative and helpful so thank you for that !
A previous problem was never resolved by Orbea/Mahle, the F20 has both an iWoc One and Trio controls fitted which originally both able to select power settings, the One stopped doing this and only turned on/off to Green, I was told Firmware Update would sort it, it didn't !

Welcome to the forums! :cool:
 
I suspect I will have to bite the bullet and replace the battery on my 2020 Orbea Gain F20 (Out of Warranty) weird figures are showing for the 'odometer' mileage etc' which were previously ok, the battery percentage appears ok and the system is operating ok at present. How were you able to link/register the new battery with the other electrical items and bike frame number ? You were impressed by EcoMove, did these people do that for you when checking out the bike, I have not contacted them as yet, the bike still operates ok and still usable as an ebike. Previously I have had the firmware updated ok by a local dealer in Wells (Scott) Mahle registered but they cannot access the Orbea Mahle Dealer App. Your saga was most informative and helpful so thank you for that !
A previous problem was never resolved by Orbea/Mahle, the F20 has both an iWoc One and Trio controls fitted which originally both able to select power settings, the One stopped doing this and only turned on/off to Green, I was told Firmware Update would sort it, it didn't !
I ordered the battery through Ecomove and fitted it myself, I didn't have to do anything to register the battery to the bike apart from connecting it to the My Smartbike App via Bluetooth (and deleting the old one). As I mentioned, It does come up as the wrong model of bike on the app and when I contacted Ribble about this they said (in the way that they always do) that it was a Mahle problem and they knew about it.

Fitting the battery is not too big a job, there's a basic video out there on YouTube showing how it's done. You will need to dissemble the headset to get the wires through the frame. I used some stiff electrical wire taped to the old wires to pull them through Ecomove can do it for you, they told me it would be an hour's work.

It might be worth taking the bike to Ecomove to see what they think of your problem, maybe there's some kind of 'reset' they could do with the dealer App?
 
Just to clarify, the VIN number and bike Model are now wrong as shown on the App. The VIN number icludes the the words 'CHANGEME' so I guess this needs to be altered. I thought Mahle would do this when I bought the new battery as they had all the info from the old bike but it obviously didn't happen. This will probably involve another lengthy email exchange with Mahle/Ribble to find out who is responsible and who might be able to change it.
 
That might be down to the Coding I was refering to and if EcoMove have the Mahle Dealers App for Ribble they may be able to do that for you. I will certainly check with them that they are an Orbea Dealer and that they have the Orbea Dealer App and then get them to Update my Firmware and check coding before launching into Battery replacement. I have removed the forks before to replace the handlebar Trio Controller and thread the wiring thro' so I'm not worried about doing that again. Good luck with your progress and hope you have sorted your bikes now !
 
Hello everyone! I'm new to the forum and it's been a great help thus far figuring out all things Mahle x35.
From what I read here, some of you had luck updating the system to the previous update Q3.2 (September 2022).
Has anyone had luck with the current latest update Q4.3? Thank you!
 
Hello everyone! I'm new to the forum and it's been a great help thus far figuring out all things Mahle x35.
From what I read here, some of you had luck updating the system to the previous update Q3.2 (September 2022).
Has anyone had luck with the current latest update Q4.3? Thank you!

Welcome to the forums! :cool:
 
HumanPerson, as you may have read above updating the firmware can be a problem (disastrous in my case!). All I would say is that if you're bike is functioning ok with the firmware you already have them don't bother to update. I wanted to update because the older firmware wouldn't work correctly with my PulsarOne controller and updating did in fact fix the issue on my bike. Sadly, during the update on my wife's bike the whole thing failed destroying the GCU cable and the battery on the bike which required £600 replacement. Probably just bad luck as I've not heard of a similar failure.
 
I trust your battery replacement is now operating fine without any problems, did you manage to get your registrations and VIN sorted satisfactorily by dealer or manufacturer ? My Orbea F20 is still operating satisfactorily on the iWoc Trio so I am leaving well alone and hoping not to have to replace controller/battery yet.
 
To be honest the bike has been laid up for winter so I haven't bothered to get the VIN sorted yet. Maybe this week if it stops raining for 5 minutes!
 
Back
Top