1800w ebay motor cuts out for long periods


New member
Local time
4:39 AM
Jun 23, 2022
I have a custom build using an ebay 1800w motor. This originally came with a 34a speed controller which worked well for a year. However that one died due to overheating and being overloaded (bad design on my part). I ordered a new controller off ebay, which has a current rating of 42a according to the sticker on it.

I have this issue where the motor will work fine but then after a few minutes it will just cut out. It will be out and not be able to start again for multiple hours. I have no idea why. The battery has a 45a bms, but that worked fine on the 34a controller. The controller is still getting power, as I'm able to measure voltage coming off of the throttle line, but the motor does not want to move. There are no noises to indicate that it's trying to move. I have tried a different throttle, no difference.
There is a time when it WORKS, and then, there is a time when it DOES NOT WORK.

It is apparently repeatable and reliable. EXCELLENT.

Now, tell me EVERYTHING you do, and EVERYTHING that happens, during that "after a few minutes" before it just cuts out.

Solution to your problem relies on YOU, telling EVERYTHING. Leave things out, and your problem is unlikely to get solved.

Also, tell me about the bad design that caused your original controller to fail. HINT - these two issues are almost certainly related.